# CVE-2024-6866: Case-Insensitive Path Matching in corydolphin/flask-cors

> Case-insensitive path matching in flask-cors allows unauthorized origins to access restricted paths, leading to data exposure.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 3 Nov 2025
- **Also known as:** CLSA-2025-1759882315, DEBIAN-CVE-2024-6866, ECHO-d5f7-cb8c-2a12, GHSA-43qf-4rqw-9q2g, PYSEC-2026-1383, ROOT-APP-PYPI-CVE-2024-6866, UBUNTU-CVE-2024-6866

## What is CVE-2024-6866?

CVE-2024-6866 is a medium-severity vulnerability in corydolphin/flask-cors, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

corydolphin/flask-cors version 4.01 contains a vulnerability where the request path matching is case-insensitive due to the use of the `try_match` function, which is originally intended for matching hosts. This results in a mismatch because paths in URLs are case-sensitive, but the regex matching treats them as case-insensitive. This misconfiguration can lead to significant security vulnerabilities, allowing unauthorized origins to access paths meant to be restricted, resulting in data exposure and potential data leaks.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2024-6866?

3 open source packages ship an affected version, including flask-cors. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-cors` | PyPI | All versions | 6.0.0 |
| `flask-cors` | PyPI | All versions | 6.0.0 |
| `flask-cors` | PyPI | All versions | 6.0.0 |

Products: Flask-Cors Project Flask-Cors.

## How do I fix CVE-2024-6866?

Upgrade flask-cors to 6.0.0 or later.

## Is CVE-2024-6866 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6866 exists.

## Other vulnerabilities in corydolphin/flask-cors

- [CVE-2024-6844](https://insights.sbomify.com/CVE-2024-6844/): Inconsistent CORS Matching Due to Handling of '+' in URL Path in corydolphin/flask-cors (medium 5.3)
- [CVE-2024-6839](https://insights.sbomify.com/CVE-2024-6839/): Improper Regex Path Matching in corydolphin/flask-cors (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6866 and fix it if it is affected.

What it is: CVE-2024-6866 is a medium-severity vulnerability in corydolphin/flask-cors, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6866 exists.

Affected packages and fixed versions:
- flask-cors (PyPI): affected all versions; fixed in 6.0.0
- flask-cors (PyPI): affected all versions; fixed in 6.0.0
- flask-cors (PyPI): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6866/ (Markdown: https://insights.sbomify.com/CVE-2024-6866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6866
- OSV: https://osv.dev/vulnerability/CVE-2024-6866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6866/
Summaries are generated and may contain mistakes; the official description above is the record.
