# CVE-2024-6886: Inproper Sanitation of field leading to stored XSS

> An attacker can inject malicious scripts into Gitea fields, leading to stored XSS that may compromise user sessions or execute code in victim browsers.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2024
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4h4p-553m-46qh, GO-2024-3056

## What is CVE-2024-6886?

CVE-2024-6886 is a critical cross-site scripting vulnerability in Gitea Open Source Git Server, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Gitea Gitea Open Source Git Server allows Stored XSS.This issue affects Gitea Open Source Git Server: 1.22.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-6886?

3 open source packages ship an affected version, including code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.22.1 |
| `code.gitea.io/gitea` | Go | All versions | 1.22.1 |
| `code.gitea.io/gitea` | Go | All versions | 1.22.1 |

## How do I fix CVE-2024-6886?

Upgrade code.gitea.io/gitea to 1.22.1 or later.

## Is CVE-2024-6886 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6886 exists.

Public exploit code:

- Gitea 1.22.0 - Cross-Site Scripting (nuclei): http/cves/2024/CVE-2024-6886.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6886 and fix it if it is affected.

What it is: CVE-2024-6886 is a critical cross-site scripting vulnerability in Gitea Open Source Git Server, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6886 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.22.1
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.22.1
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6886/ (Markdown: https://insights.sbomify.com/CVE-2024-6886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6886
- OSV: https://osv.dev/vulnerability/CVE-2024-6886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6886/
Summaries are generated and may contain mistakes; the official description above is the record.
