# CVE-2024-6982: Remote Code Execution in Calculate Function in parisneo/lollms

> Attackers can execute arbitrary code on the server by bypassing a Python sandbox in the Calculate function using importlib tricks.

- **Severity:** High 8.4 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-jccx-m9v4-9hwh, PYSEC-2026-1591

## What is CVE-2024-6982?

CVE-2024-6982 is a high-severity code injection vulnerability in parisneo/lollms, published on 20 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A remote code execution vulnerability exists in the Calculate function of parisneo/lollms version 9.8. The vulnerability arises from the use of Python's `eval()` function to evaluate mathematical expressions within a Python sandbox that disables `__builtins__` and only allows functions from the `math` module. This sandbox can be bypassed by loading the `os` module using the `_frozen_importlib.BuiltinImporter` class, allowing an attacker to execute arbitrary commands on the server. The issue is fixed in version 9.10.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-6982?

3 open source packages ship an affected version, including lollms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 11.0.0 |
| `lollms` | PyPI | All versions | 11.0.0 |
| `lollms` | PyPI | All versions | 11.0.0 |

## How do I fix CVE-2024-6982?

Upgrade lollms to 11.0.0 or later.

## Is CVE-2024-6982 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6982 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6982 and fix it if it is affected.

What it is: CVE-2024-6982 is a high-severity code injection vulnerability in parisneo/lollms, published on 20 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6982 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 11.0.0
- lollms (PyPI): affected all versions; fixed in 11.0.0
- lollms (PyPI): affected all versions; fixed in 11.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6982/ (Markdown: https://insights.sbomify.com/CVE-2024-6982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6982
- OSV: https://osv.dev/vulnerability/CVE-2024-6982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6982/
Summaries are generated and may contain mistakes; the official description above is the record.
