# CVE-2024-6985: Path Traversal in api open_personality_folder in parisneo/lollms-webui

> An attacker can read arbitrary files on the victim's computer via path traversal in the open_personality_folder API endpoint of lollms-webui.

- **Severity:** Medium 4.4 (`CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2024
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-6h64-g7cj-hj56, PYSEC-2024-122

## What is CVE-2024-6985?

CVE-2024-6985 is a medium-severity path traversal vulnerability in parisneo/lollms, published on 11 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A path traversal vulnerability exists in the api open_personality_folder endpoint of parisneo/lollms-webui. This vulnerability allows an attacker to read any folder in the personality_folder on the victim's computer, even though sanitize_path is set. The issue arises due to improper sanitization of the personality_folder parameter, which can be exploited to traverse directories and access arbitrary files.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2024-6985?

3 open source packages ship an affected version, including lollms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions to 9.5.1 | None |
| `lollms` | PyPI | All versions to 9.5.1 | None |
| `lollms` | PyPI | All versions | 5.9.0 |

Products: Lollms Lollms.

## How do I fix CVE-2024-6985?

Upgrade lollms to 5.9.0 or later.

## Is CVE-2024-6985 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6985 exists.

## Other vulnerabilities in parisneo/lollms

- [CVE-2026-1114](https://insights.sbomify.com/CVE-2026-1114/): Improper Access Control via Weak JWT Token in parisneo/lollms (critical 9.8)
- [CVE-2024-3429](https://insights.sbomify.com/CVE-2024-3429/): Path Traversal in parisneo/lollms (critical 9.8)
- [CVE-2026-1115](https://insights.sbomify.com/CVE-2026-1115/): Stored XSS in parisneo/lollms (critical 9.6)
- [CVE-2026-12228](https://insights.sbomify.com/CVE-2026-12228/): Stored XSS in Direct Messages via Prompt Sharing in parisneo/lollms (high 8.7)
- [CVE-2026-0562](https://insights.sbomify.com/CVE-2026-0562/): Insecure Direct Object Reference (IDOR) in parisneo/lollms (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6985 and fix it if it is affected.

What it is: CVE-2024-6985 is a medium-severity path traversal vulnerability in parisneo/lollms, published on 11 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6985 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions up to 9.5.1; no fix listed
- lollms (PyPI): affected all versions up to 9.5.1; no fix listed
- lollms (PyPI): affected all versions; fixed in 5.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6985/ (Markdown: https://insights.sbomify.com/CVE-2024-6985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6985
- OSV: https://osv.dev/vulnerability/CVE-2024-6985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6985/
Summaries are generated and may contain mistakes; the official description above is the record.
