# CVE-2024-7035: Cross-Site Request Forgery (CSRF) in open-webui/open-webui

> Attackers can trick users into performing sensitive actions like resetting data via GET requests, compromising integrity and availability.

- **Severity:** Medium 6.9 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-p5vx-9hj8-cf4h, PYSEC-2026-1739

## What is CVE-2024-7035?

CVE-2024-7035 is a medium-severity vulnerability in Openwebui Open Webui, published on 20 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

In version v0.3.8 of open-webui/open-webui, sensitive actions such as deleting and resetting are performed using the GET method. This vulnerability allows an attacker to perform Cross-Site Request Forgery (CSRF) attacks, where an unaware user can unintentionally perform sensitive actions by simply visiting a malicious site or through top-level navigation. The affected endpoints include /rag/api/v1/reset, /rag/api/v1/reset/db, /api/v1/memories/reset, and /rag/api/v1/reset/uploads. This impacts both the availability and integrity of the application.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-7035?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions to 0.3.8 | None |
| `open-webui` | PyPI | All versions to 0.3.8 | None |
| `open-webui` | PyPI | All versions | 0.3.16 |

Products: Openwebui Open Webui.

## How do I fix CVE-2024-7035?

Upgrade open-webui to 0.3.16 or later.

## Is CVE-2024-7035 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7035 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7035 and fix it if it is affected.

What it is: CVE-2024-7035 is a medium-severity vulnerability in Openwebui Open Webui, published on 20 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7035 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions up to 0.3.8; no fix listed
- open-webui (PyPI): affected all versions up to 0.3.8; no fix listed
- open-webui (PyPI): affected all versions; fixed in 0.3.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7035/ (Markdown: https://insights.sbomify.com/CVE-2024-7035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7035
- OSV: https://osv.dev/vulnerability/CVE-2024-7035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7035/
Summaries are generated and may contain mistakes; the official description above is the record.
