# CVE-2024-7042: Prompt Injection in langchain-ai/langchainjs Leading to SQL Injection

> Prompt injection in GraphCypherQAChain allows attackers to execute SQL commands, leading to data theft, modification, or deletion.

- **Severity:** Medium 4.9 (`CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2024
- **Updated:** 15 Oct 2025
- **Also known as:** CLEANSTART-2026-BU53237, ECHO-f514-af32-e2e9, GHSA-6m59-8fmv-m5f9, MINI-5p47-gvq3-6hgc

## What is CVE-2024-7042?

CVE-2024-7042 is a medium-severity SQL injection vulnerability in langchain-ai/langchainjs, published on 29 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection, leading to SQL injection. This vulnerability permits unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-7042?

2 open source packages ship an affected version, including @langchain/community. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@langchain/community` | npm | All versions | 0.3.3 |
| `@langchain/community` | npm | All versions | 0.3.3 |

Products: Langchain Langchain.

## How do I fix CVE-2024-7042?

Upgrade @langchain/community to 0.3.3 or later.

## Is CVE-2024-7042 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7042 exists.

## Other vulnerabilities in langchain-ai/langchainjs

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7042 and fix it if it is affected.

What it is: CVE-2024-7042 is a medium-severity SQL injection vulnerability in langchain-ai/langchainjs, published on 29 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7042 exists.

Affected packages and fixed versions:
- @langchain/community (npm): affected all versions; fixed in 0.3.3
- @langchain/community (npm): affected all versions; fixed in 0.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7042/ (Markdown: https://insights.sbomify.com/CVE-2024-7042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7042
- OSV: https://osv.dev/vulnerability/CVE-2024-7042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7042/
Summaries are generated and may contain mistakes; the official description above is the record.
