CVE-2024-7047 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 7.7 Published Updated

An attacker can execute arbitrary scripts in the context of a logged-in user via a cross-site scripting vulnerability in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-7047?

CVE-2024-7047 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 25 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A cross site scripting vulnerability exists in GitLab CE/EE affecting all versions from 16.6 prior to 17.0.5, 17.1 prior to 17.1.3, 17.2 prior to 17.2.1 allowing an attacker to execute arbitrary scripts under the context of the current logged in user.

Weakness: CWE-79

Which versions are affected by CVE-2024-7047?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.6.017.0.5, 17.1.3, 17.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-7047?

Upgrade gitlab to a fixed version for your release line: 17.0.5, 17.1.3 or 17.2.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-7047 being exploited?

There is no known exploitation of CVE-2024-7047 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-7047, GHSA-x8pf-46vx-rg97.

Is CVE-2024-7047 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free