CVE-2024-7055 FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

Medium 6.9 Published Updated

Remote attackers can trigger a heap-based buffer overflow in FFmpeg's PNM decoder, potentially leading to code execution or denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-7055?

CVE-2024-7055 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

Weakness: CWE-787, CWE-122

Which versions are affected by CVE-2024-7055?

It affects 1 product.

Linux distribution packages (7)
ffmpeg-4 SUSE:Linux Enterprise Module for Package Hub 15 SP6All versions4.4-150600.13.13.1
ffmpeg-4 SUSE:Linux Enterprise Workstation Extension 15 SP6All versions4.4-150600.13.13.1
ffmpeg-4 openSUSE:Leap 15.6All versions4.4-150600.13.13.1
ffmpeg-4 openSUSE:TumbleweedAll versions4.4.4-14.1
ffmpeg-5 openSUSE:TumbleweedAll versions5.1.4-13.1
ffmpeg-6 openSUSE:TumbleweedAll versions6.1.1-9.1
ffmpeg-7 openSUSE:TumbleweedAll versions7.1-1.1

Products include Ffmpeg Ffmpeg.

How do I fix CVE-2024-7055?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-7055 being exploited?

There is no known exploitation of CVE-2024-7055 in the wild and no public exploit code.

All Ffmpeg Ffmpeg vulnerabilities

Sources

Also known as DEBIAN-CVE-2024-7055, GHSA-5gxm-744m-qfgp, JLSEC-2025-133, OESA-2024-2075, ROOT-OS-UBUNTU-2204-CVE-2024-7055, SUSE-SU-2024:3301-1 and 5 more.

Is CVE-2024-7055 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free