{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-7055 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-7055 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-7055 and fix it if it is affected.\n\nWhat it is: CVE-2024-7055 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-7055 in the wild and no public exploit code.\n\nAffected product: Ffmpeg Ffmpeg. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-7055/ (Markdown: https://insights.sbomify.com/CVE-2024-7055/index.md)","id":"CVE-2024-7055","markdown":"https://insights.sbomify.com/CVE-2024-7055/index.md","name":"CVE-2024-7055","record":{"aliases":["DEBIAN-CVE-2024-7055","GHSA-5gxm-744m-qfgp","JLSEC-2025-133","OESA-2024-2075","ROOT-OS-UBUNTU-2204-CVE-2024-7055","SUSE-SU-2024:3301-1","UBUNTU-CVE-2024-7055","openSUSE-SU-2024:14339-1","openSUSE-SU-2024:14343-1","openSUSE-SU-2024:14344-1","openSUSE-SU-2024:14384-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"FFmpeg multimedia library","requires_auth":"none","summary":"Remote attackers can trigger a heap-based buffer overflow in FFmpeg's PNM decoder, potentially leading to code execution or denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ffmpeg","vendor":"ffmpeg"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.","ecosystems":["SUSE:Linux Enterprise Module for Package Hub 15 SP6","SUSE:Linux Enterprise Workstation Extension 15 SP6","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FFmpeg pnmdec.c pnm_decode_frame heap-based overflow","id":"CVE-2024-7055","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"ffmpeg:ffmpeg","products":["ffmpeg:ffmpeg"],"type":"memory_corruption","year":"2024"},"n_packages":7,"n_references":6,"next":{"headline":"WPForms \u003c 1.9.1.6 - Admin+ Stored XSS","id":"CVE-2024-7056"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["4.4-150600.13.13.1"],"introduced":["0"],"last_affected":[],"package":"ffmpeg-4","purl":"pkg:rpm/suse/ffmpeg-4\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2024:3301-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 15 SP6","fixed":["4.4-150600.13.13.1"],"introduced":["0"],"last_affected":[],"package":"ffmpeg-4","purl":"pkg:rpm/suse/ffmpeg-4\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2015%20SP6","source":"SUSE-SU-2024:3301-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["4.4-150600.13.13.1"],"introduced":["0"],"last_affected":[],"package":"ffmpeg-4","purl":"pkg:rpm/opensuse/ffmpeg-4\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2024:3301-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.4.4-14.1"],"introduced":["0"],"last_affected":[],"package":"ffmpeg-4","purl":"pkg:rpm/opensuse/ffmpeg-4\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14343-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.1.4-13.1"],"introduced":["0"],"last_affected":[],"package":"ffmpeg-5","purl":"pkg:rpm/opensuse/ffmpeg-5\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14339-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.1.1-9.1"],"introduced":["0"],"last_affected":[],"package":"ffmpeg-6","purl":"pkg:rpm/opensuse/ffmpeg-6\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14344-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["7.1-1.1"],"introduced":["0"],"last_affected":[],"package":"ffmpeg-7","purl":"pkg:rpm/opensuse/ffmpeg-7\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14384-1"}],"prev":{"headline":"Popup Maker \u003c= 1.19.0 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2024-7054"},"products":["FFmpeg"],"published":"2024-08-06","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2013-0864","kev_date_added":null,"published":"2013-11-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2013-0872","kev_date_added":null,"published":"2013-11-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2013-0873","kev_date_added":null,"published":"2013-11-23"},{"cvss_score":10,"headline":"Null dereference in n/a","id":"CVE-2013-4265","kev_date_added":null,"published":"2013-11-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3937","kev_date_added":null,"published":"2013-01-05"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2772","kev_date_added":null,"published":"2012-09-10"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2775","kev_date_added":null,"published":"2012-09-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"Remote attackers can trigger a heap-based buffer overflow in FFmpeg's PNM decoder, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2024-7055/"}