# CVE-2024-7055: FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

> Remote attackers can trigger a heap-based buffer overflow in FFmpeg's PNM decoder, potentially leading to code execution or denial of service.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2024
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-7055, GHSA-5gxm-744m-qfgp, JLSEC-2025-133, OESA-2024-2075, ROOT-OS-UBUNTU-2204-CVE-2024-7055, SUSE-SU-2024:3301-1, UBUNTU-CVE-2024-7055, openSUSE-SU-2024:14339-1, openSUSE-SU-2024:14343-1, openSUSE-SU-2024:14344-1, openSUSE-SU-2024:14384-1

## What is CVE-2024-7055?

CVE-2024-7055 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2024-7055?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ffmpeg-4` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.4-150600.13.13.1 |
| `ffmpeg-4` | SUSE:Linux Enterprise Workstation Extension 15 SP6 | All versions | 4.4-150600.13.13.1 |
| `ffmpeg-4` | openSUSE:Leap 15.6 | All versions | 4.4-150600.13.13.1 |
| `ffmpeg-4` | openSUSE:Tumbleweed | All versions | 4.4.4-14.1 |
| `ffmpeg-5` | openSUSE:Tumbleweed | All versions | 5.1.4-13.1 |
| `ffmpeg-6` | openSUSE:Tumbleweed | All versions | 6.1.1-9.1 |
| `ffmpeg-7` | openSUSE:Tumbleweed | All versions | 7.1-1.1 |

Products: Ffmpeg Ffmpeg.

## How do I fix CVE-2024-7055?

Upgrade to a fixed version.

## Is CVE-2024-7055 being exploited?

There is no known exploitation of CVE-2024-7055 in the wild and no public exploit code.

## Other vulnerabilities in Ffmpeg Ffmpeg

- [CVE-2013-0864](https://insights.sbomify.com/CVE-2013-0864/): Memory corruption in n/a (critical 10.0)
- [CVE-2013-0872](https://insights.sbomify.com/CVE-2013-0872/): Memory corruption in n/a (critical 10.0)
- [CVE-2013-0873](https://insights.sbomify.com/CVE-2013-0873/): Memory corruption in n/a (critical 10.0)
- [CVE-2013-4265](https://insights.sbomify.com/CVE-2013-4265/): Null dereference in n/a (critical 10.0)
- [CVE-2011-3937](https://insights.sbomify.com/CVE-2011-3937/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7055 and fix it if it is affected.

What it is: CVE-2024-7055 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-7055 in the wild and no public exploit code.

Affected product: Ffmpeg Ffmpeg. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7055/ (Markdown: https://insights.sbomify.com/CVE-2024-7055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7055
- OSV: https://osv.dev/vulnerability/CVE-2024-7055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7055/
Summaries are generated and may contain mistakes; the official description above is the record.
