CVE-2024-7057 Improper Access Control in GitLab

Medium 4.3 Published Updated

Attackers with low privileges can access job artifacts they are not authorized to view, leading to information disclosure.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-7057?

CVE-2024-7057 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 25 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An information disclosure vulnerability in GitLab CE/EE affecting all versions starting from 16.7 prior to 17.0.5, starting from 17.1 prior to 17.1.3, and starting from 17.2 prior to 17.2.1 where job artifacts can be inappropriately exposed to users lacking the proper authorization level.

Weakness: CWE-284

Which versions are affected by CVE-2024-7057?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.7.017.0.5, 17.1.3, 17.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-7057?

Upgrade gitlab to a fixed version for your release line: 17.0.5, 17.1.3 or 17.2.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-7057 being exploited?

There is no known exploitation of CVE-2024-7057 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-7057, GHSA-h3pp-hqpg-9qmw, UBUNTU-CVE-2024-7057.

Is CVE-2024-7057 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free