{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-7094 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-7094 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-7094 is a critical code injection vulnerability in rabilal JS Help Desk – AI-Powered Support \u0026 Ticketing System, published on 13 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-7094 and fix it if it is affected.\n\nWhat it is: CVE-2024-7094 is a critical code injection vulnerability in rabilal JS Help Desk – AI-Powered Support \u0026 Ticketing System, published on 13 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-7094 in the wild and no public exploit code.\n\nAffected product: rabilal JS Help Desk – AI-Powered Support \u0026 Ticketing System. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-7094/ (Markdown: https://insights.sbomify.com/CVE-2024-7094/index.md)","id":"CVE-2024-7094","markdown":"https://insights.sbomify.com/CVE-2024-7094/index.md","name":"CVE-2024-7094","record":{"aliases":["GHSA-344g-jvx4-773r"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary PHP code on the server via the JS Help Desk WordPress plugin due to insufficient input sanitization.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The JS Help Desk – The Ultimate Help Desk \u0026 Support Plugin plugin for WordPress is vulnerable to PHP Code Injection leading to Remote Code Execution in all versions up to, and including, 2.8.6 via the 'storeTheme' function. This is due to a lack of sanitization on user-supplied values, which replace values in the style.php file, along with missing capability checks. This makes it possible for unauthenticated attackers to execute code on the server. This issue was partially patched in 2.8.6 when the code injection issue was resolved, and fully patched in 2.8.7 when the missing authorization and cross-site request forgery protection was added. CVE-2024-43274 is likely a duplicate of this issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2024-08-18","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-08-18T09:27:54Z","kind":"github_poc","ref":"https://github.com/nastar-id/CVE-2024-7094","stars":0,"title":"CVE-2024-7094 Vulnerability checker"}],"tier":"poc_unverified"},"has_fix":null,"headline":"Code injection in JS Help Desk – AI-Powered Support \u0026 Ticketing System","id":"CVE-2024-7094","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":0,"n_references":6,"next":{"headline":"Denial of service in EOS","id":"CVE-2024-7095"},"packages":[],"prev":{"headline":"Server-Side Template Injection in Dispatch Message Templates","id":"CVE-2024-7093"},"products":["JS Help Desk – AI-Powered Support \u0026 Ticketing System"],"published":"2024-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["rabilal"]},"summary":"Unauthenticated attackers can execute arbitrary PHP code on the server via the JS Help Desk WordPress plugin due to insufficient input sanitization.","url":"https://insights.sbomify.com/CVE-2024-7094/"}