# CVE-2024-7096: Privilege Escalation in Multiple WSO2 Products via SOAP Admin Service Due to Business Logic Flaw

> Attackers can escalate privileges by creating users with elevated permissions via SOAP admin services in specific non-default WSO2 configurations.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 3 Dec 2025
- **Also known as:** GHSA-j63j-7r7r-5v4j

## What is CVE-2024-7096?

CVE-2024-7096 is a medium-severity vulnerability in Wso2 Api Manager, published on 30 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A privilege escalation vulnerability exists in multiple WSO2 products due to a business logic flaw in SOAP admin services. A malicious actor can create a new user with elevated permissions only when all of the following conditions are met:
  *  SOAP admin services are accessible to the attacker.
  *  The deployment includes an internally used attribute that is not part of the default WSO2 product configuration.
  *  At least one custom role exists with non-default permissions.
  *  The attacker has knowledge of the custom role and the internal attribute used in the deployment.

Exploiting this vulnerability allows malicious actors to assign higher privileges to self-registered users, bypassing intended access control mechanisms.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-7096?

4 open source packages ship an affected version, including org.wso2.am:am-parent and org.wso2.is:identity-server-parent. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wso2.am:am-parent` | Maven | From 2.0.0 | 4.4.0 |
| `org.wso2.am:am-parent` | Maven | From 2.0.0 | 4.4.0 |
| `org.wso2.is:identity-server-parent` | Maven | From 5.2.0 | 7.1.0 |
| `org.wso2.is:identity-server-parent` | Maven | From 5.2.0 | 7.1.0 |

Products: Wso2 Api Manager, Wso2 Identity Server, Wso2 Identity Server as Key Manager, Wso2 Open Banking Am, Wso2 Open Banking Iam, Wso2 Open Banking Km.

## How do I fix CVE-2024-7096?

Upgrade org.wso2.am:am-parent to 4.4.0 or later.

## Is CVE-2024-7096 being exploited?

There is no known exploitation of CVE-2024-7096 in the wild and no public exploit code.

## Other vulnerabilities in Wso2 Api Manager

- [CVE-2022-29464](https://insights.sbomify.com/CVE-2022-29464/): WSO2 Multiple Products Unrestrictive Upload of File (critical 9.8, exploited in the wild)
- [CVE-2024-6914](https://insights.sbomify.com/CVE-2024-6914/): Incorrect Authorization in Multiple WSO2 Products via Account Recovery SOAP Admin Service Leading to Account Takeover (critical 9.8)
- [CVE-2020-13226](https://insights.sbomify.com/CVE-2020-13226/): WSO2 API Manager vulnerable to SSRF (critical 9.8)
- [CVE-2025-2905](https://insights.sbomify.com/CVE-2025-2905/): An XML External Entity (XXE) vulnerability in Multiple WSO2 Products (critical 9.1)
- [CVE-2021-42646](https://insights.sbomify.com/CVE-2021-42646/): XML external entity in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7096 and fix it if it is affected.

What it is: CVE-2024-7096 is a medium-severity vulnerability in Wso2 Api Manager, published on 30 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-7096 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wso2.am:am-parent (Maven): affected from 2.0.0; fixed in 4.4.0
- org.wso2.am:am-parent (Maven): affected from 2.0.0; fixed in 4.4.0
- org.wso2.is:identity-server-parent (Maven): affected from 5.2.0; fixed in 7.1.0
- org.wso2.is:identity-server-parent (Maven): affected from 5.2.0; fixed in 7.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7096/ (Markdown: https://insights.sbomify.com/CVE-2024-7096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7096
- OSV: https://osv.dev/vulnerability/CVE-2024-7096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7096/
Summaries are generated and may contain mistakes; the official description above is the record.
