CVE-2024-7110 Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab
Attackers can execute arbitrary commands in victim pipelines via prompt injection in GitLab EE, requiring immediate upgrades.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-7110?
CVE-2024-7110 is a medium-severity command injection vulnerability in Gitlab Gitlab, published on 22 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue was discovered in GitLab EE affecting all versions starting 17.0 to 17.1.6, 17.2 prior to 17.2.4, and 17.3 prior to 17.3.1 allows an attacker to execute arbitrary command in a victim's pipeline through prompt injection.
Weakness: CWE-77
Which versions are affected by CVE-2024-7110?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.1.0 | 17.1.6, 17.2.4, 17.3.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-7110?
Upgrade gitlab to a fixed version for your release line: 17.1.6, 17.2.4 or 17.3.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2024-7110 being exploited?
There is no known exploitation of CVE-2024-7110 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-7110, GHSA-px82-82wp-3w57, UBUNTU-CVE-2024-7110.