CVE-2024-7272 FFmpeg swresample.c fill_audiodata heap-based overflow
Remote attackers can trigger a heap-based buffer overflow in FFmpeg's audio resampling, potentially leading to code execution or crashes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-7272?
CVE-2024-7272 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.
Which versions are affected by CVE-2024-7272?
It affects 1 product.
Linux distribution packages (1)
ffmpeg-5 openSUSE:Tumbleweed | All versions | 5.1.4-11.1 |
Products include Ffmpeg Ffmpeg.
How do I fix CVE-2024-7272?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2024-7272 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7272 exists.
Other vulnerabilities in Ffmpeg Ffmpeg
Sources
Also known as DEBIAN-CVE-2024-7272, GHSA-7q2g-j3r8-hgwh, JLSEC-2025-134, openSUSE-SU-2024:14290-1.