{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7272 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-7272 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-7272 and fix it if it is affected.\n\nWhat it is: CVE-2024-7272 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7272 exists.\n\nAffected product: Ffmpeg Ffmpeg. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-7272/ (Markdown: https://insights.sbomify.com/CVE-2024-7272/index.md)","id":"CVE-2024-7272","markdown":"https://insights.sbomify.com/CVE-2024-7272/index.md","name":"CVE-2024-7272","record":{"aliases":["DEBIAN-CVE-2024-7272","GHSA-7q2g-j3r8-hgwh","JLSEC-2025-134","openSUSE-SU-2024:14290-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"FFmpeg audio library","requires_auth":"none","summary":"Remote attackers can trigger a heap-based buffer overflow in FFmpeg's audio resampling, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ffmpeg","vendor":"ffmpeg"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FFmpeg swresample.c fill_audiodata heap-based overflow","id":"CVE-2024-7272","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"ffmpeg:ffmpeg","products":["ffmpeg:ffmpeg"],"type":"memory_corruption","year":"2024"},"n_packages":1,"n_references":5,"next":{"headline":"itsourcecode Alton Management System search.php sql injection","id":"CVE-2024-7273"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.1.4-11.1"],"introduced":["0"],"last_affected":[],"package":"ffmpeg-5","purl":"pkg:rpm/opensuse/ffmpeg-5\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14290-1"}],"prev":{"headline":"Stored XSS in ConnX ESP HR Management","id":"CVE-2024-7269"},"products":["FFmpeg"],"published":"2024-08-08","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2013-0864","kev_date_added":null,"published":"2013-11-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2013-0872","kev_date_added":null,"published":"2013-11-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2013-0873","kev_date_added":null,"published":"2013-11-23"},{"cvss_score":10,"headline":"Null dereference in n/a","id":"CVE-2013-4265","kev_date_added":null,"published":"2013-11-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3937","kev_date_added":null,"published":"2013-01-05"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2772","kev_date_added":null,"published":"2012-09-10"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2775","kev_date_added":null,"published":"2012-09-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-09","vendors":["n/a"]},"summary":"Remote attackers can trigger a heap-based buffer overflow in FFmpeg's audio resampling, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2024-7272/"}