# CVE-2024-7272: FFmpeg swresample.c fill_audiodata heap-based overflow

> Remote attackers can trigger a heap-based buffer overflow in FFmpeg's audio resampling, potentially leading to code execution or crashes.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2024
- **Updated:** 9 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-7272, GHSA-7q2g-j3r8-hgwh, JLSEC-2025-134, openSUSE-SU-2024:14290-1

## What is CVE-2024-7272?

CVE-2024-7272 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2024-7272?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ffmpeg-5` | openSUSE:Tumbleweed | All versions | 5.1.4-11.1 |

Products: Ffmpeg Ffmpeg.

## How do I fix CVE-2024-7272?

Upgrade to a fixed version.

## Is CVE-2024-7272 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7272 exists.

## Other vulnerabilities in Ffmpeg Ffmpeg

- [CVE-2013-0864](https://insights.sbomify.com/CVE-2013-0864/): Memory corruption in n/a (critical 10.0)
- [CVE-2013-0872](https://insights.sbomify.com/CVE-2013-0872/): Memory corruption in n/a (critical 10.0)
- [CVE-2013-0873](https://insights.sbomify.com/CVE-2013-0873/): Memory corruption in n/a (critical 10.0)
- [CVE-2013-4265](https://insights.sbomify.com/CVE-2013-4265/): Null dereference in n/a (critical 10.0)
- [CVE-2011-3937](https://insights.sbomify.com/CVE-2011-3937/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7272 and fix it if it is affected.

What it is: CVE-2024-7272 is a medium-severity memory corruption vulnerability in Ffmpeg Ffmpeg, published on 8 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7272 exists.

Affected product: Ffmpeg Ffmpeg. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7272/ (Markdown: https://insights.sbomify.com/CVE-2024-7272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7272
- OSV: https://osv.dev/vulnerability/CVE-2024-7272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7272/
Summaries are generated and may contain mistakes; the official description above is the record.
