{"answers":{"affected":"3 open source packages ship an affected version, including weave.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7340 exists.","fix":"Upgrade weave to 0.50.8 or later.","what":"CVE-2024-7340 is a high-severity path traversal vulnerability in weave, published on 31 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-7340 and fix it if it is affected.\n\nWhat it is: CVE-2024-7340 is a high-severity path traversal vulnerability in weave, published on 31 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7340 exists.\n\nAffected packages and fixed versions:\n- weave (PyPI): affected all versions; fixed in 0.50.8\n- weave (PyPI): affected all versions; fixed in 0.50.8\n- weave (PyPI): affected all versions; fixed in 0.50.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-7340/ (Markdown: https://insights.sbomify.com/CVE-2024-7340/index.md)","id":"CVE-2024-7340","markdown":"https://insights.sbomify.com/CVE-2024-7340/index.md","name":"CVE-2024-7340","record":{"aliases":["GHSA-r49h-6qxq-624f","PYSEC-2026-2035"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"W\u0026B Weave server","requires_auth":"low_privilege","summary":"Remote attackers can traverse directories to leak arbitrary files and escalate privileges to admin in the W\u0026B Weave server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"JFROG","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The Weave server API allows remote users to fetch files from a specific directory, but due to a lack of input validation, it is possible to traverse and leak arbitrary files remotely. In various common scenarios, this allows a low-privileged user to assume the role of the server admin.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-7340.yaml","stars":null,"title":"W\u0026B Weave Server - Remote Arbitrary File Leak"}],"tier":"weaponised"},"has_fix":true,"headline":"W\u0026B Weave server remote arbitrary file leak and privilege escalation","id":"CVE-2024-7340","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Wildfly-elytron: org.keycloak/keycloak-services: session fixation in elytron saml adapters","id":"CVE-2024-7341"},"packages":[{"ecosystem":"PyPI","fixed":["0.50.8"],"introduced":["0"],"last_affected":[],"package":"weave","purl":null,"source":"GHSA-r49h-6qxq-624f"},{"ecosystem":"PyPI","fixed":["0.50.8"],"introduced":["0"],"last_affected":[],"package":"weave","purl":"pkg:pypi/weave","source":"GHSA-r49h-6qxq-624f"},{"ecosystem":"PyPI","fixed":["0.50.8"],"introduced":["0"],"last_affected":[],"package":"weave","purl":"pkg:pypi/weave","source":"PYSEC-2026-2035"}],"prev":{"headline":"TVT DVR TD-2104TS-CL queryDevInfo information disclosure","id":"CVE-2024-7339"},"products":[],"published":"2024-07-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-25","vendors":[]},"summary":"Remote attackers can traverse directories to leak arbitrary files and escalate privileges to admin in the W\u0026B Weave server.","url":"https://insights.sbomify.com/CVE-2024-7340/"}