CVE-2024-7394 Concrete CMS version 9.0.0 through 9.3.2 and below 8.5.18 - Stored XSS in getAttributeSetName()
A rogue administrator can inject malicious scripts via the getAttributeSetName function, leading to stored cross-site scripting attacks.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-7394?
CVE-2024-7394 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 8 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Concrete CMS versions 9 through 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in getAttributeSetName(). A rogue administrator could inject malicious code. The Concrete CMS team gave this a CVSS v4.0 rank of 4.6 with vector https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N. Thanks, m3dium for reporting. (CNA updated this risk rank on 20 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)
Weakness: CWE-79
Which versions are affected by CVE-2024-7394?
4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 8.5.18 |
concrete5/concrete5 Packagist | All versions | 8.5.18 |
concrete5/concrete5 Packagist | From 9.0.0 | 9.3.3 |
concrete5/concrete5 Packagist | From 9.0.0 | 9.3.3 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2024-7394?
Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.18 or 9.3.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-7394 being exploited?
There is no known exploitation of CVE-2024-7394 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-w6j6-w6jx-vf2r.