# CVE-2024-7398: Concrete CMS Stored XSS Vulnerability in Calendar Event Addition Feature

> Attackers with calendar permissions can inject scripts via event names, leading to stored XSS attacks against other users.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Sep 2024
- **Updated:** 20 Jan 2025
- **Also known as:** GHSA-x8h2-255q-jg4x

## What is CVE-2024-7398?

CVE-2024-7398 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 24 Sep 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Concrete CMS versions 9 through 9.3.3 and versions below 8.5.19 are vulnerable to stored XSS in the calendar event addition feature because the calendar event name was not sanitized on output. Users or groups with permission to create event calendars can embed scripts, and users or groups with permission to modify event calendars can execute scripts. The Concrete CMS Security Team gave this vulnerability a CVSS v4 score of 4.6 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N Thank you, Yusuke Uchida for reporting. CNA updated this risk rank on 20 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-7398?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 8.5.19 |
| `concrete5/concrete5` | Packagist | All versions | 8.5.19 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.3.4 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.3.4 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2024-7398?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.19 or 9.3.4.

## Is CVE-2024-7398 being exploited?

There is no known exploitation of CVE-2024-7398 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7398 and fix it if it is affected.

What it is: CVE-2024-7398 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 24 Sep 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-7398 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.19
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.19
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.3.4
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7398/ (Markdown: https://insights.sbomify.com/CVE-2024-7398/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7398
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7398
- OSV: https://osv.dev/vulnerability/CVE-2024-7398

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7398/
Summaries are generated and may contain mistakes; the official description above is the record.
