CVE-2024-7404 Improper Restriction of Rendered UI Layers or Frames in GitLab
An attacker can gain full API access as the victim via the Device OAuth flow due to improper UI layer restrictions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-7404?
CVE-2024-7404 is a medium-severity vulnerability in Gitlab Gitlab, published on 14 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 17.2 prior to 17.3.7, starting from 17.4 prior to 17.4.4 and starting from 17.5 prior to 17.5.2, which could have allowed an attacker gaining full API access as the victim via the Device OAuth flow.
Weakness: CWE-1021
Which versions are affected by CVE-2024-7404?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.2.0 | 17.3.7, 17.4.4, 17.5.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-7404?
Upgrade gitlab to a fixed version for your release line: 17.3.7, 17.4.4 or 17.5.2.
Is CVE-2024-7404 being exploited?
There is no known exploitation of CVE-2024-7404 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-7404, GHSA-f7c4-9mmj-8w4v.