CVE-2024-7476 Broken Access Control in lunary-ai/lunary
An authenticated attacker can modify any user's templates by sending a crafted HTTP POST request to the templates endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-7476?
CVE-2024-7476 is a medium-severity missing authorization vulnerability in Lunary Lunary, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A broken access control vulnerability exists in lunary-ai/lunary versions 1.2.7 through 1.4.2. The vulnerability allows an authenticated attacker to modify any user's templates by sending a crafted HTTP POST request to the /v1/templates/{id}/versions endpoint. This issue is resolved in version 1.4.3.
Weakness: CWE-639
Which versions are affected by CVE-2024-7476?
It affects 1 product.
Products include Lunary Lunary.
How do I fix CVE-2024-7476?
No fix has been published for CVE-2024-7476 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-7476 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7476 exists.
Other vulnerabilities in Lunary Lunary
- CVE-2024-8999 Improper Access Control in lunary-ai/lunary
- CVE-2024-9095 Improper Authorization in lunary-ai/lunary
- CVE-2024-7456 SQL Injection in lunary-ai/lunary
- CVE-2024-4146 Incorrect Authorization in lunary-ai/lunary
- CVE-2024-5386 Account Hijacking via Password Reset Token Leak in lunary-ai/lunary
Sources
Also known as GHSA-9xvx-2953-c58g.