CVE-2024-7512 Concrete CMS Stored XSS in Board instances
A stored XSS vulnerability in Concrete CMS Board instances allows a rogue administrator to inject malicious code, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-7512?
CVE-2024-7512 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Concrete CMS versions 9.0.0 through 9.3.2 are affected by a stored XSS vulnerability in Board instances. A rogue administrator could inject malicious code. The Concrete CMS security team gave this vulnerability a CVSS 4.0 Score of 4.6 with vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N. Versions below 9 are not affected. Thanks, m3dium for reporting. (CNA updated AC score to L based on CVSS 4.0 documentation)
Which versions are affected by CVE-2024-7512?
2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | From 9.0.0RC1 | 9.3.3 |
concrete5/concrete5 Packagist | From 9.0.0RC1 | 9.3.3 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2024-7512?
Upgrade concrete5/concrete5 to 9.3.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-7512 being exploited?
There is no known exploitation of CVE-2024-7512 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-c47w-9mcf-w972.