# CVE-2024-7512: Concrete CMS Stored XSS in Board instances

> A stored XSS vulnerability in Concrete CMS Board instances allows a rogue administrator to inject malicious code, potentially leading to code execution or account takeover.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Aug 2024
- **Updated:** 17 Jan 2025
- **Also known as:** GHSA-c47w-9mcf-w972

## What is CVE-2024-7512?

CVE-2024-7512 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Concrete CMS versions 9.0.0 through 9.3.2 are affected by a stored XSS vulnerability in Board instances. A rogue administrator could inject malicious code. The Concrete CMS security team gave this vulnerability a CVSS 4.0 Score of 4.6 with vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N. Versions below 9 are not affected. Thanks, m3dium for reporting. (CNA updated AC score to L based on CVSS 4.0 documentation)

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-7512?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | From 9.0.0RC1 | 9.3.3 |
| `concrete5/concrete5` | Packagist | From 9.0.0RC1 | 9.3.3 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2024-7512?

Upgrade concrete5/concrete5 to 9.3.3 or later.

## Is CVE-2024-7512 being exploited?

There is no known exploitation of CVE-2024-7512 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7512 and fix it if it is affected.

What it is: CVE-2024-7512 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 9 Aug 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-7512 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected from 9.0.0RC1; fixed in 9.3.3
- concrete5/concrete5 (Packagist): affected from 9.0.0RC1; fixed in 9.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7512/ (Markdown: https://insights.sbomify.com/CVE-2024-7512/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7512
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7512
- OSV: https://osv.dev/vulnerability/CVE-2024-7512

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7512/
Summaries are generated and may contain mistakes; the official description above is the record.
