# CVE-2024-7553: Accessing Untrusted Directory May Allow Local Privilege Escalation

> Local attackers on Windows can escalate privileges by placing malicious files in an untrusted directory loaded by MongoDB.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2024
- **Updated:** 7 Aug 2024
- **Also known as:** BIT-mongodb-2024-7553, GHSA-5m47-pw5x-gvrc, JLSEC-2026-180, UBUNTU-CVE-2024-7553

## What is CVE-2024-7553?

CVE-2024-7553 is a high-severity vulnerability in Mongodb Mongodb, published on 7 Aug 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Incorrect validation of files loaded from a local untrusted directory may allow local privilege escalation if the underlying operating systems is Windows. This may result in the application executing arbitrary behaviour determined by the contents of untrusted files. This issue affects MongoDB Server v5.0 versions prior to 5.0.27, MongoDB Server v6.0 versions prior to 6.0.16, MongoDB Server v7.0 versions prior to 7.0.12, MongoDB Server v7.3 versions prior 7.3.3, MongoDB C Driver versions prior to 1.26.2 and MongoDB PHP Driver versions prior to 1.18.1.

Required Configuration:

Only environments with Windows as the underlying operating system is affected by this issue

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-7553?

1 open source package ship an affected version, including mongodb. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 5.0.0 | 5.0.27, 6.0.16, 7.0.12 |

Products: Mongodb C Driver, Mongodb Mongodb, Mongodb Php Driver.

## How do I fix CVE-2024-7553?

Upgrade mongodb to a fixed version for your release line: 5.0.27, 6.0.16 or 7.0.12.

## Is CVE-2024-7553 being exploited?

There is no known exploitation of CVE-2024-7553 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2026-93393](https://insights.sbomify.com/CVE-2026-93393/): Heap overflow via oversized decrypted TLS record sequence in Windows Secure Channel stream (critical 9.2)
- [CVE-2026-6691](https://insights.sbomify.com/CVE-2026-6691/): MongoDB C Driver Cyrus SASL Canonicalization Buffer Overflow (high 8.6)
- [CVE-2026-84964](https://insights.sbomify.com/CVE-2026-84964/): Heap corruption via OCSP request double free from crafted multi-URL certificate in TLS client (high 8.2)
- [CVE-2026-93395](https://insights.sbomify.com/CVE-2026-93395/): Integer Underflow → Heap Out-of-Bounds Read in `bson_new_from_buffer() (medium 6.9)
- [CVE-2025-12119](https://insights.sbomify.com/CVE-2025-12119/): Bulk write with options may read invalid memory (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7553 and fix it if it is affected.

What it is: CVE-2024-7553 is a high-severity vulnerability in Mongodb Mongodb, published on 7 Aug 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-7553 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 5.0.0; fixed in 5.0.27, 6.0.16, 7.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7553/ (Markdown: https://insights.sbomify.com/CVE-2024-7553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7553
- OSV: https://osv.dev/vulnerability/CVE-2024-7553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7553/
Summaries are generated and may contain mistakes; the official description above is the record.
