CVE-2024-7554 Exposure of Sensitive Information to an Unauthorized Actor in GitLab
Attackers can obtain sensitive access tokens from logs if specific API requests are made, potentially leading to unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-7554?
CVE-2024-7554 is a medium-severity vulnerability in Gitlab Gitlab, published on 8 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.9 before 17.0.6, all versions starting from 17.1 before 17.1.4, all versions starting from 17.2 before 17.2.2. Under certain conditions, access tokens may have been logged when an API request was made in a specific manner.
Weakness: CWE-200
Which versions are affected by CVE-2024-7554?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.9.0 | 17.0.6, 17.1.4, 17.2.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-7554?
Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.
Is CVE-2024-7554 being exploited?
There is no known exploitation of CVE-2024-7554 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-7554, GHSA-8hq6-8c4w-ggxc, UBUNTU-CVE-2024-7554.