# CVE-2024-7594: Vault SSH Secrets Engine Configuration Did Not Restrict Valid Principals By Default

> Attackers with authorized access can authenticate as any user on SSH hosts if Vault's SSH engine lacks valid_principals configuration.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2024
- **Updated:** 10 Jan 2025
- **Also known as:** BIT-openbao-2024-7594, BIT-vault-2024-7594, GHSA-jg74-mwgw-v6x3, GO-2024-3162

## What is CVE-2024-7594?

CVE-2024-7594 is a high-severity missing authorization vulnerability in Hashicorp Vault, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vault’s SSH secrets engine did not require the valid_principals list to contain a value by default. If the valid_principals and default_user fields of the SSH secrets engine configuration are not set, an SSH certificate requested by an authorized user to Vault’s SSH secrets engine could be used to authenticate as any user on the host. Fixed in Vault Community Edition 1.17.6, and in Vault Enterprise 1.17.6, 1.16.10, and 1.15.15.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2024-7594?

9 open source packages ship an affected version, including github.com/hashicorp/vault, openbao and vault. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.7.7 | 1.17.6 |
| `github.com/hashicorp/vault` | Go | From 1.7.7 | 1.17.6 |
| `github.com/hashicorp/vault` | Go | From 1.7.7 | 1.17.6 |
| `openbao` | Bitnami | All versions | 2.0.2 |
| `vault` | Bitnami | From 1.7.7 | 1.17.6 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20241003222810-d5b4e9224698 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20241003222810-d5b4e9224698 |
| `github.com/openbao/openbao` | Go | From 0.1.0 | None |
| `github.com/openbao/openbao` | Go | From 0.1.0 | None |

Products: Hashicorp Vault, Openbao Openbao.

## How do I fix CVE-2024-7594?

Upgrade github.com/hashicorp/vault to 1.17.6 or later.

## Is CVE-2024-7594 being exploited?

There is no known exploitation of CVE-2024-7594 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7594 and fix it if it is affected.

What it is: CVE-2024-7594 is a high-severity missing authorization vulnerability in Hashicorp Vault, published on 26 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-7594 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.7.7; fixed in 1.17.6
- github.com/hashicorp/vault (Go): affected from 1.7.7; fixed in 1.17.6
- github.com/hashicorp/vault (Go): affected from 1.7.7; fixed in 1.17.6
- openbao (Bitnami): affected all versions; fixed in 2.0.2
- vault (Bitnami): affected from 1.7.7; fixed in 1.17.6
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20241003222810-d5b4e9224698
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20241003222810-d5b4e9224698
- github.com/openbao/openbao (Go): affected from 0.1.0; no fix listed
- github.com/openbao/openbao (Go): affected from 0.1.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7594/ (Markdown: https://insights.sbomify.com/CVE-2024-7594/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7594
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7594
- OSV: https://osv.dev/vulnerability/CVE-2024-7594

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7594/
Summaries are generated and may contain mistakes; the official description above is the record.
