CVE-2024-7610 Uncontrolled Resource Consumption in GitLab

Medium 4.3 Published Updated

An attacker can cause a Denial of Service in GitLab by triggering catastrophic backtracking during Elasticsearch result parsing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-7610?

CVE-2024-7610 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 8 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Denial of Service (DoS) condition has been discovered in GitLab CE/EE affecting all versions starting with 15.9 before 17.0.6, 17.1 prior to 17.1.4, and 17.2 prior to 17.2.2. It is possible for an attacker to cause catastrophic backtracking while parsing results from Elasticsearch.

Weakness: CWE-400

Which versions are affected by CVE-2024-7610?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.9.017.0.6, 17.1.4, 17.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-7610?

Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-7610 being exploited?

There is no known exploitation of CVE-2024-7610 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-7610, GHSA-f48g-wqmg-9r45, UBUNTU-CVE-2024-7610.

Is CVE-2024-7610 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free