# CVE-2024-7625: Nomad Vulnerable to Allocation Directory Escape On Non-Existing File Paths Through Archive Unpacking

> Attackers with client agent access can write files outside the allocation directory via archive unpacking, potentially leading to code execution.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Aug 2024
- **Updated:** 9 Jan 2025
- **Also known as:** GHSA-25qx-vfw2-fw8r, GO-2024-3073, UBUNTU-CVE-2024-7625

## What is CVE-2024-7625?

CVE-2024-7625 is a medium-severity path traversal vulnerability in HashiCorp Nomad, published on 14 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In HashiCorp Nomad and Nomad Enterprise from 0.6.1 up to 1.6.13, 1.7.10, and 1.8.2, the archive unpacking process is vulnerable to writes outside the allocation directory during migration of allocation directories when multiple archive headers target the same file. This vulnerability, CVE-2024-7625, is fixed in Nomad 1.6.14, 1.7.11, and 1.8.3. Access or compromise of the Nomad client agent at the source allocation first is a prerequisite for leveraging this vulnerability.

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere)

## Which versions are affected by CVE-2024-7625?

7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | From 0.6.1 | 1.6.14 |
| `github.com/hashicorp/nomad` | Go | From 0.6.1 | 1.6.14 |
| `github.com/hashicorp/nomad` | Go | From 0.6.1 | 1.8.3 |
| `github.com/hashicorp/nomad` | Go | From 1.7.0 | 1.7.11 |
| `github.com/hashicorp/nomad` | Go | From 1.7.0 | 1.7.11 |
| `github.com/hashicorp/nomad` | Go | From 1.8.0 | 1.8.3 |
| `github.com/hashicorp/nomad` | Go | From 1.8.0 | 1.8.3 |

Products: Hashicorp Nomad.

## How do I fix CVE-2024-7625?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.6.14, 1.8.3 or 1.7.11.

## Is CVE-2024-7625 being exploited?

There is no known exploitation of CVE-2024-7625 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Nomad

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7625 and fix it if it is affected.

What it is: CVE-2024-7625 is a medium-severity path traversal vulnerability in HashiCorp Nomad, published on 14 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-7625 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected from 0.6.1; fixed in 1.6.14
- github.com/hashicorp/nomad (Go): affected from 0.6.1; fixed in 1.6.14
- github.com/hashicorp/nomad (Go): affected from 0.6.1; fixed in 1.8.3
- github.com/hashicorp/nomad (Go): affected from 1.7.0; fixed in 1.7.11
- github.com/hashicorp/nomad (Go): affected from 1.7.0; fixed in 1.7.11
- github.com/hashicorp/nomad (Go): affected from 1.8.0; fixed in 1.8.3
- github.com/hashicorp/nomad (Go): affected from 1.8.0; fixed in 1.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7625/ (Markdown: https://insights.sbomify.com/CVE-2024-7625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7625
- OSV: https://osv.dev/vulnerability/CVE-2024-7625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7625/
Summaries are generated and may contain mistakes; the official description above is the record.
