{"answers":{"affected":"1 open source package ship an affected version, including nginx-agent. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-7634 in the wild and no public exploit code.","fix":"Upgrade nginx-agent to 2.37.0 or later.","what":"CVE-2024-7634 is a medium-severity path traversal vulnerability in F5 NGINX Agent, published on 22 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-7634 and fix it if it is affected.\n\nWhat it is: CVE-2024-7634 is a medium-severity path traversal vulnerability in F5 NGINX Agent, published on 22 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-7634 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-agent (Bitnami): affected from 2.17.0; fixed in 2.37.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-7634/ (Markdown: https://insights.sbomify.com/CVE-2024-7634/index.md)","id":"CVE-2024-7634","markdown":"https://insights.sbomify.com/CVE-2024-7634/index.md","name":"CVE-2024-7634","record":{"aliases":["BIT-nginx-agent-2024-7634","GHSA-f3wr-j648-3c97"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"NGINX Agent","requires_auth":"high_privilege","summary":"A privileged attacker can write or overwrite files outside the secure directory due to a path traversal flaw in NGINX Agent.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_agent","vendor":"f5"},{"product":"nginx_instance_manager","vendor":"f5"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"NGINX Agent's \"config_dirs\" restriction feature allows a highly privileged attacker to gain the ability to write/overwrite files outside of the designated secure directory.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX Agent Vulnerability","id":"CVE-2024-7634","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"code-projects Simple Ticket Booking Registration register_insert.php sql injection","id":"CVE-2024-7635"},"packages":[{"ecosystem":"Bitnami","fixed":["2.37.0"],"introduced":["2.17.0"],"last_affected":[],"package":"nginx-agent","purl":"pkg:bitnami/nginx-agent","source":"BIT-nginx-agent-2024-7634"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2024-7633"},"products":["NGINX Agent"],"published":"2024-08-22","related":[{"cvss_score":5.5,"headline":"NGINX Agent vulnerability CVE-2023-1550","id":"CVE-2023-1550","kev_date_added":null,"published":"2023-03-29"},{"cvss_score":5.3,"headline":"NGINX Agent Vulnerability","id":"CVE-2026-60062","kev_date_added":null,"published":"2026-07-15"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-22","vendors":["F5"]},"summary":"A privileged attacker can write or overwrite files outside the secure directory due to a path traversal flaw in NGINX Agent.","url":"https://insights.sbomify.com/CVE-2024-7634/"}