# CVE-2024-7634: NGINX Agent Vulnerability

> A privileged attacker can write or overwrite files outside the secure directory due to a path traversal flaw in NGINX Agent.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2024
- **Updated:** 22 Aug 2024
- **Also known as:** BIT-nginx-agent-2024-7634, GHSA-f3wr-j648-3c97

## What is CVE-2024-7634?

CVE-2024-7634 is a medium-severity path traversal vulnerability in F5 NGINX Agent, published on 22 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

NGINX Agent's "config_dirs" restriction feature allows a highly privileged attacker to gain the ability to write/overwrite files outside of the designated secure directory.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-7634?

1 open source package ship an affected version, including nginx-agent. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx-agent` | Bitnami | From 2.17.0 | 2.37.0 |

Products: F5 Nginx Agent, F5 Nginx Instance Manager.

## How do I fix CVE-2024-7634?

Upgrade nginx-agent to 2.37.0 or later.

## Is CVE-2024-7634 being exploited?

There is no known exploitation of CVE-2024-7634 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Agent

- [CVE-2023-1550](https://insights.sbomify.com/CVE-2023-1550/): NGINX Agent vulnerability CVE-2023-1550 (medium 5.5)
- [CVE-2026-60062](https://insights.sbomify.com/CVE-2026-60062/): NGINX Agent Vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7634 and fix it if it is affected.

What it is: CVE-2024-7634 is a medium-severity path traversal vulnerability in F5 NGINX Agent, published on 22 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-7634 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx-agent (Bitnami): affected from 2.17.0; fixed in 2.37.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7634/ (Markdown: https://insights.sbomify.com/CVE-2024-7634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7634
- OSV: https://osv.dev/vulnerability/CVE-2024-7634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7634/
Summaries are generated and may contain mistakes; the official description above is the record.
