# CVE-2024-7776: Arbitrary File Overwrite in onnx/onnx

> Attackers can overwrite arbitrary files via malicious tar archives in the download_model function, potentially leading to remote code execution.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** AZL-59201, DEBIAN-CVE-2024-7776, GHSA-h36j-8vv3-cj52, PYSEC-2025-10, UBUNTU-CVE-2024-7776

## What is CVE-2024-7776?

CVE-2024-7776 is a high-severity path traversal vulnerability in onnx/onnx, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability in the `download_model` function of the onnx/onnx framework, before and including version 1.16.1, allows for arbitrary file overwrite due to inadequate prevention of path traversal attacks in malicious tar files. This vulnerability can be exploited by an attacker to overwrite files in the user's directory, potentially leading to remote command execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-7776?

3 open source packages ship an affected version, including onnx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `onnx` | PyPI | All versions | 1.16.2 |
| `onnx` | PyPI | All versions | 1.17.0 |
| `onnx` | PyPI | All versions | 1.17.0 |

Products: Onnx Onnx.

## How do I fix CVE-2024-7776?

Upgrade onnx to a fixed version for your release line: 1.16.2 or 1.17.0.

## Is CVE-2024-7776 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7776 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-7776 and fix it if it is affected.

What it is: CVE-2024-7776 is a high-severity path traversal vulnerability in onnx/onnx, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7776 exists.

Affected packages and fixed versions:
- onnx (PyPI): affected all versions; fixed in 1.16.2
- onnx (PyPI): affected all versions; fixed in 1.17.0
- onnx (PyPI): affected all versions; fixed in 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-7776/ (Markdown: https://insights.sbomify.com/CVE-2024-7776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-7776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-7776
- OSV: https://osv.dev/vulnerability/CVE-2024-7776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-7776/
Summaries are generated and may contain mistakes; the official description above is the record.
