CVE-2024-7884 Memory leak when calling a canister method via `ic_cdk::call`
An attacker can trigger heap memory exhaustion in Rust canisters by exploiting a memory leak in the ic_cdk library, causing denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-7884?
CVE-2024-7884 is a high-severity denial of service vulnerability in Internet Computer ic-cdk, published on 5 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When a canister method is called via ic_cdk::call* , a new Future CallFuture is created and can be awaited by the caller to get the execution result. Internally, the state of the Future is tracked and stored in a struct called CallFutureState. A bug in the polling implementation of the CallFuture allows multiple references to be held for this internal state and not all references were dropped before the Future is resolved. Since we have unaccounted references held, a copy of the internal state ended up being persisted in the canister's heap and thus causing a memory leak. Impact Canisters built in Rust with ic_cdk and ic_cdk_timers are affected. If these canisters call a canister method, use timers or heartbeat, they will likely leak a small amount of memory on every such operation. In the worst case, this could lead to heap memory exhaustion triggered by an attacker. Motoko based canisters are not affected by the bug. PatchesThe patch has been backported to all minor versions between >= 0.8.0, <= 0.15.0. The patched versions available are 0.8.2, 0.9.3, 0.10.1, 0.11.6, 0.12.2, 0.13.5, 0.14.1, 0.15.1 and their previous versions have been yanked. WorkaroundsThere are no known workarounds at the moment. Developers are recommended to upgrade their canister as soon as possible to the latest available patched version of ic_cdk to avoid running out of Wasm heap memory. Upgrading the canisters (without updating `ic_cdk`) also frees the leaked memory but it's only a temporary solution.
Weakness: CWE-401
Which versions are affected by CVE-2024-7884?
17 open source packages ship an affected version, including ic_cdk and ic-cdk. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ic_cdk crates.io | From 0.10.0 | 0.10.1 |
ic_cdk crates.io | From 0.10.0 | 0.10.1 |
ic_cdk crates.io | From 0.11.0 | 0.11.6 |
ic_cdk crates.io | From 0.11.0 | 0.11.6 |
ic_cdk crates.io | From 0.12.0 | 0.12.2 |
ic_cdk crates.io | From 0.12.0 | 0.12.2 |
11 more packages
ic_cdk crates.io | From 0.13.0 | 0.13.5 |
ic_cdk crates.io | From 0.13.0 | 0.13.5 |
ic_cdk crates.io | From 0.14.0 | 0.14.1 |
ic_cdk crates.io | From 0.14.0 | 0.14.1 |
ic_cdk crates.io | From 0.15.0 | 0.15.1 |
ic_cdk crates.io | From 0.15.0 | 0.15.1 |
ic_cdk crates.io | From 0.8.0 | 0.8.2 |
ic_cdk crates.io | From 0.8.0 | 0.8.2 |
ic_cdk crates.io | From 0.9.0 | 0.9.3 |
ic_cdk crates.io | From 0.9.0 | 0.9.3 |
ic-cdk crates.io | From 0.8.0 | 0.8.2, 0.9.3, 0.10.1, 0.11.6, 0.12.2, 0.13.5, 0.14.1, 0.15.1, 0.16.0 |
Products include Dfinity Canister Developer Kit for the Internet Computer.
How do I fix CVE-2024-7884?
Upgrade ic_cdk to a fixed version for your release line: 0.10.1, 0.11.6, 0.12.2 or 0.13.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-7884 being exploited?
There is no known exploitation of CVE-2024-7884 in the wild and no public exploit code.
Sources
Also known as GHSA-rwq6-crjg-9cpw, RUSTSEC-2024-0372.