CVE-2024-7928 FastAdmin lang path traversal

Medium 5.3 Published Updated

Remote attackers can exploit a path traversal vulnerability in FastAdmin to read arbitrary files from the server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-7928?

CVE-2024-7928 is a medium-severity path traversal vulnerability in FastAdmin, published on 19 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability, which was classified as problematic, has been found in FastAdmin up to 1.3.3.20220121. Affected by this issue is some unknown functionality of the file /index/ajax/lang. The manipulation of the argument lang leads to path traversal. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.3.4.20220530 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-22

Which versions are affected by CVE-2024-7928?

It affects 1 product.

Products include Fastadmin Fastadmin.

How do I fix CVE-2024-7928?

No fix has been published for CVE-2024-7928 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2024-7928 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-7928 exists.

Public exploit code: 1 Nuclei template and 4 proofs of concept on GitHub.

Sources

Also known as GHSA-gp9j-wjxg-4r78.

Is CVE-2024-7928 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free