{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8005 exists.","fix":"No fix has been published for CVE-2024-8005 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-8005 is a medium-severity vulnerability in demozx gf_cms, published on 20 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8005 and fix it if it is affected.\n\nWhat it is: CVE-2024-8005 is a medium-severity vulnerability in demozx gf_cms, published on 20 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8005 exists.\n\nAffected product: demozx gf_cms. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8005/ (Markdown: https://insights.sbomify.com/CVE-2024-8005/index.md)","id":"CVE-2024-8005","markdown":"https://insights.sbomify.com/CVE-2024-8005/index.md","name":"CVE-2024-8005","record":{"aliases":["GHSA-r39x-24mw-vr93"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Go CMS","requires_auth":"none","summary":"Hard-coded credentials in the JWT authentication module allow remote attackers to gain unauthorized access and escalate privileges.","user_interaction":"not_required","vuln_class":"hardcoded_credentials"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"gf_cms","vendor":"demozx"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-798","name":"Use of Hard-coded Credentials"}],"description":"A vulnerability was found in demozx gf_cms 1.0/1.0.1. It has been classified as critical. This affects the function init of the file internal/logic/auth/auth.go of the component JWT Authentication. The manipulation leads to hard-coded credentials. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.2 is able to address this issue. The patch is named be702ada7cb6fdabc02689d90b38139c827458a5. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"demozx gf_cms JWT Authentication auth.go init hard-coded credentials","id":"CVE-2024-8005","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"hardcoded_credentials","year":"2024"},"n_packages":0,"n_references":7,"next":{"headline":"NULL pointer dereference in libpcap before 1.10.5 with remote packet capture support","id":"CVE-2024-8006"},"packages":[],"prev":{"headline":"Cross-site scripting in ENOVIA Collaborative Industry Innovator","id":"CVE-2024-8004"},"products":["gf_cms"],"published":"2024-08-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-20","vendors":["demozx"]},"summary":"Hard-coded credentials in the JWT authentication module allow remote attackers to gain unauthorized access and escalate privileges.","url":"https://insights.sbomify.com/CVE-2024-8005/"}