# CVE-2024-8008: Reflected Cross-Site Scripting (XSS) in Multiple WSO2 Products via JDBC User Store Connection Validation

> Attackers can inject JavaScript into WSO2 products via JDBC validation errors, enabling UI manipulation or data exfiltration, though session hijacking is prevented.

- **Severity:** Medium 5.2 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jun 2025
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-xpxp-r8hf-wgf6

## What is CVE-2024-8008?

CVE-2024-8008 is a medium-severity cross-site scripting vulnerability in Wso2 Api Manager, published on 2 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A reflected cross-site scripting (XSS) vulnerability exists in multiple WSO2 products due to insufficient output encoding in error messages generated by the JDBC user store connection validation request. A malicious actor can inject a specially crafted payload into the request, causing the browser to execute arbitrary JavaScript in the context of the vulnerable page.

This vulnerability may allow UI manipulation, redirection to malicious websites, or data exfiltration from the browser. However, since all session-related sensitive cookies are protected with the httpOnly flag, session hijacking is not possible.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-8008?

2 open source packages ship an affected version, including org.wso2.carbon.identity.framework:org.wso2.carbon.identity.user.store.configuration.ui. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wso2.carbon.identity.framework:org.wso2.carbon.identity.user.store.configuration.ui` | Maven | All versions | 7.5.12 |
| `org.wso2.carbon.identity.framework:org.wso2.carbon.identity.user.store.configuration.ui` | Maven | All versions | 7.5.12 |

Products: Wso2 Api Manager, Wso2 Enterprise Integrator, Wso2 Identity Server, Wso2 Identity Server as Key Manager, Wso2 Open Banking Am, Wso2 Open Banking Iam.

## How do I fix CVE-2024-8008?

Upgrade org.wso2.carbon.identity.framework:org.wso2.carbon.identity.user.store.configuration.ui to 7.5.12 or later.

## Is CVE-2024-8008 being exploited?

There is no known exploitation of CVE-2024-8008 in the wild and no public exploit code.

## Other vulnerabilities in Wso2 Api Manager

- [CVE-2022-29464](https://insights.sbomify.com/CVE-2022-29464/): WSO2 Multiple Products Unrestrictive Upload of File (critical 9.8, exploited in the wild)
- [CVE-2024-6914](https://insights.sbomify.com/CVE-2024-6914/): Incorrect Authorization in Multiple WSO2 Products via Account Recovery SOAP Admin Service Leading to Account Takeover (critical 9.8)
- [CVE-2020-13226](https://insights.sbomify.com/CVE-2020-13226/): WSO2 API Manager vulnerable to SSRF (critical 9.8)
- [CVE-2025-2905](https://insights.sbomify.com/CVE-2025-2905/): An XML External Entity (XXE) vulnerability in Multiple WSO2 Products (critical 9.1)
- [CVE-2021-42646](https://insights.sbomify.com/CVE-2021-42646/): XML external entity in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8008 and fix it if it is affected.

What it is: CVE-2024-8008 is a medium-severity cross-site scripting vulnerability in Wso2 Api Manager, published on 2 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-8008 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wso2.carbon.identity.framework:org.wso2.carbon.identity.user.store.configuration.ui (Maven): affected all versions; fixed in 7.5.12
- org.wso2.carbon.identity.framework:org.wso2.carbon.identity.user.store.configuration.ui (Maven): affected all versions; fixed in 7.5.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8008/ (Markdown: https://insights.sbomify.com/CVE-2024-8008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8008
- OSV: https://osv.dev/vulnerability/CVE-2024-8008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8008/
Summaries are generated and may contain mistakes; the official description above is the record.
