CVE-2024-8041 Uncontrolled Resource Consumption in GitLab

Medium 6.5 Published Updated

An attacker can cause a denial of service in GitLab by importing a maliciously crafted repository using the GitHub importer.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-8041?

CVE-2024-8041 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 22 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Denial of Service (DoS) issue has been discovered in GitLab CE/EE affecting all versions prior to 17.1.6, 17.2 prior to 17.2.4, and 17.3 prior to 17.3.1. A denial of service could occur upon importing a maliciously crafted repository using the GitHub importer.

Weakness: CWE-400

Which versions are affected by CVE-2024-8041?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions17.1.6, 17.2.4, 17.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-8041?

Upgrade gitlab to a fixed version for your release line: 17.1.6, 17.2.4 or 17.3.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-8041 being exploited?

There is no known exploitation of CVE-2024-8041 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8041, GHSA-qvhh-qrj8-5g7c, UBUNTU-CVE-2024-8041.

Is CVE-2024-8041 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free