CVE-2024-8114 Missing Authorization in GitLab

High 8.2 Published Updated

An attacker with a victim's Personal Access Token can escalate privileges due to missing authorization checks in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-8114?

CVE-2024-8114 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 8.12 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. This issue allows an attacker with access to a victim's Personal Access Token (PAT) to escalate privileges.

Weakness: CWE-862

Which versions are affected by CVE-2024-8114?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.12.017.4.5, 17.5.3, 17.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-8114?

Upgrade gitlab to a fixed version for your release line: 17.4.5, 17.5.3 or 17.6.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-8114 being exploited?

There is no known exploitation of CVE-2024-8114 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8114, GHSA-f5r5-77wf-xx6h, UBUNTU-CVE-2024-8114.

Is CVE-2024-8114 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free