CVE-2024-8124 Inefficient Regular Expression Complexity in GitLab

High 7.5 Published Updated

An attacker can cause a denial of service in GitLab by sending a specific POST request that triggers inefficient regular expression complexity.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-8124?

CVE-2024-8124 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 16.4 prior to 17.1.7, starting from 17.2 prior to 17.2.5, starting from 17.3 prior to 17.3.2 which could cause Denial of Service via sending a specific POST request.

Weakness: CWE-1333

Which versions are affected by CVE-2024-8124?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.4.017.1.7, 17.2.5, 17.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-8124?

Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-8124 being exploited?

There is no known exploitation of CVE-2024-8124 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8124, GHSA-9w7f-mwxm-3g85, UBUNTU-CVE-2024-8124.

Is CVE-2024-8124 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free