CVE-2024-8177 Inefficient Algorithmic Complexity in GitLab

Medium 5.3 Published Updated

An attacker can cause a denial of service in GitLab by integrating a malicious Harbor registry, requiring specific configuration changes.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-8177?

CVE-2024-8177 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 15.6 prior to 17.4.5, starting from 17.5 prior to 17.5.3, starting from 17.6 prior to 17.6.1 which could cause Denial of Service via integrating a malicious harbor registry.

Weakness: CWE-407

Which versions are affected by CVE-2024-8177?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.6.017.4.5, 17.5.3, 17.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-8177?

Upgrade gitlab to a fixed version for your release line: 17.4.5, 17.5.3 or 17.6.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-8177 being exploited?

There is no known exploitation of CVE-2024-8177 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8177, GHSA-94xw-8rg2-4fmc, UBUNTU-CVE-2024-8177.

Is CVE-2024-8177 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free