CVE-2024-8180 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Medium 5.4 Published Updated

Attackers can execute arbitrary scripts in user browsers via improper output encoding in GitLab, requiring CSP to be disabled for exploitation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-8180?

CVE-2024-8180 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 14 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.3 before 17.3.7, 17.4 before 17.4.4, and 17.5 before 17.5.2. Improper output encoding could lead to XSS if CSP is not enabled.

Weakness: CWE-79

Which versions are affected by CVE-2024-8180?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.3.017.3.7, 17.4.4, 17.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-8180?

Upgrade gitlab to a fixed version for your release line: 17.3.7, 17.4.4 or 17.5.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-8180 being exploited?

There is no known exploitation of CVE-2024-8180 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8180, GHSA-p932-x66g-q6cc.

Is CVE-2024-8180 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free