# CVE-2024-8185: Vault Vulnerable to Denial of Service When Processing Raft Join Requests

> Attackers can cause denial of service in HashiCorp Vault by exhausting memory via Raft join requests, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2024
- **Updated:** 31 Oct 2024
- **Also known as:** BIT-openbao-2024-8185, BIT-vault-2024-8185, GHSA-g233-2p4r-3q7v, GO-2024-3246

## What is CVE-2024-8185?

CVE-2024-8185 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vault Community and Vault Enterprise (“Vault”) clusters using Vault’s Integrated Storage backend are vulnerable to a denial-of-service (DoS) attack through memory exhaustion through a Raft cluster join API endpoint . An attacker may send a large volume of requests to the endpoint which may cause Vault to consume excessive system memory resources, potentially leading to a crash of the underlying system and the Vault process itself.

This vulnerability, CVE-2024-8185, is fixed in Vault Community 1.18.1 and Vault Enterprise 1.18.1, 1.17.8, and 1.16.12.

Weakness: CWE-636 (Not Failing Securely)

## Which versions are affected by CVE-2024-8185?

7 open source packages ship an affected version, including github.com/hashicorp/vault, openbao and vault. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.2.0 | 1.18.1 |
| `github.com/hashicorp/vault` | Go | From 1.2.0 | 1.18.1 |
| `github.com/hashicorp/vault` | Go | From 1.2.0 | 1.18.1 |
| `openbao` | Bitnami | All versions | 2.0.3 |
| `vault` | Bitnami | From 1.2.0 | 1.18.1 |
| `github.com/openbao/openbao` | Go | All versions | 2.0.3 |
| `github.com/openbao/openbao` | Go | All versions | 2.0.3 |

Products: Hashicorp Vault, Openbao Openbao.

## How do I fix CVE-2024-8185?

Upgrade github.com/hashicorp/vault to 1.18.1 or later.

## Is CVE-2024-8185 being exploited?

There is no known exploitation of CVE-2024-8185 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8185 and fix it if it is affected.

What it is: CVE-2024-8185 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-8185 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.2.0; fixed in 1.18.1
- github.com/hashicorp/vault (Go): affected from 1.2.0; fixed in 1.18.1
- github.com/hashicorp/vault (Go): affected from 1.2.0; fixed in 1.18.1
- openbao (Bitnami): affected all versions; fixed in 2.0.3
- vault (Bitnami): affected from 1.2.0; fixed in 1.18.1
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.0.3
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8185/ (Markdown: https://insights.sbomify.com/CVE-2024-8185/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8185
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8185
- OSV: https://osv.dev/vulnerability/CVE-2024-8185

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8185/
Summaries are generated and may contain mistakes; the official description above is the record.
