# CVE-2024-8207: MongoDB Server binaries may load potentially insecure shared libraries from specific relative paths

> Local attackers can execute arbitrary code by placing malicious libraries in specific paths, requiring host access and specific Linux configurations.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2024
- **Updated:** 16 May 2025
- **Also known as:** BIT-mongodb-2024-8207, GHSA-52jj-6w68-3m25

## What is CVE-2024-8207?

CVE-2024-8207 is a medium-severity path traversal vulnerability in Mongodb Mongodb, published on 27 Aug 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In certain highly specific configurations of the host system and MongoDB server binary installation on Linux Operating Systems, it may be possible for a unintended actor with host-level access to cause the MongoDB Server binary to load unintended actor-controlled shared libraries when the server binary is started, potentially resulting in the unintended actor gaining full control over the MongoDB server process. This issue affects MongoDB Server v5.0 versions prior to 5.0.14 and MongoDB Server v6.0 versions prior to 6.0.3.

Required Configuration: Only environments with Linux as the underlying operating system is affected by this issue

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere), CWE-114 (Process Control)

## Which versions are affected by CVE-2024-8207?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 5.0.0 | 5.0.26, 6.0.14, 7.0.7 |

Products: Mongodb Mongodb.

## How do I fix CVE-2024-8207?

Upgrade mongodb to a fixed version for your release line: 5.0.26, 6.0.14 or 7.0.7.

## Is CVE-2024-8207 being exploited?

There is no known exploitation of CVE-2024-8207 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8207 and fix it if it is affected.

What it is: CVE-2024-8207 is a medium-severity path traversal vulnerability in Mongodb Mongodb, published on 27 Aug 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-8207 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 5.0.0; fixed in 5.0.26, 6.0.14, 7.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8207/ (Markdown: https://insights.sbomify.com/CVE-2024-8207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8207
- OSV: https://osv.dev/vulnerability/CVE-2024-8207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8207/
Summaries are generated and may contain mistakes; the official description above is the record.
