# CVE-2024-8243: Plugin Upgrade Time Out <= 1.0 - Stored XSS via CSRF

> Attackers can inject stored XSS payloads via CSRF, potentially compromising admin accounts in the Plugin Upgrade Time Out WordPress plugin.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Apr 2025
- **Updated:** 9 Apr 2025
- **Also known as:** GHSA-c846-2c33-mpmm

## What is CVE-2024-8243?

CVE-2024-8243 is a medium-severity cross-site scripting vulnerability in Unknown WordPress/Plugin Upgrade Time Out Plugin, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The WordPress/Plugin Upgrade Time Out Plugin WordPress plugin through 1.0 does not have CSRF check in some places, and is missing sanitisation as well as escaping, which could allow attackers to make logged in admin add Stored XSS payloads via a CSRF attack.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-8243?

It affects 1 product.


Products: Felixker Wordpress\/Plugin Upgrade Time Out Plugin.

## How do I fix CVE-2024-8243?

No fix has been published for CVE-2024-8243 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-8243 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8243 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8243 and fix it if it is affected.

What it is: CVE-2024-8243 is a medium-severity cross-site scripting vulnerability in Unknown WordPress/Plugin Upgrade Time Out Plugin, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8243 exists.

Affected product: Unknown WordPress/Plugin Upgrade Time Out Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8243/ (Markdown: https://insights.sbomify.com/CVE-2024-8243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8243
- OSV: https://osv.dev/vulnerability/CVE-2024-8243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8243/
Summaries are generated and may contain mistakes; the official description above is the record.
