# CVE-2024-8291: Concrete CMS Stored XSS in Image Editor Background Color

> A rogue admin can inject malicious scripts via the Image Editor Background Color field, leading to stored XSS attacks against other users.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2024
- **Updated:** 17 Jan 2025
- **Also known as:** GHSA-q7qr-22qw-pqgx

## What is CVE-2024-8291?

CVE-2024-8291 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 24 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Concrete CMS versions 9.0.0 to 9.3.3 and below 8.5.19 are vulnerable to Stored XSS in Image Editor Background Color.  A rogue admin could add malicious code to the Thumbnails/Add-Type. The Concrete CMS Security Team gave this a CVSS v4 score of 5.1 with vector   https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N. Thanks,  Alexey Solovyev for reporting. (CNA updated this risk rank on 17 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-8291?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 8.5.19 |
| `concrete5/concrete5` | Packagist | All versions | 8.5.19 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.3.4 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.3.4 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2024-8291?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.19 or 9.3.4.

## Is CVE-2024-8291 being exploited?

There is no known exploitation of CVE-2024-8291 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8291 and fix it if it is affected.

What it is: CVE-2024-8291 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 24 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-8291 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.19
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.19
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.3.4
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8291/ (Markdown: https://insights.sbomify.com/CVE-2024-8291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8291
- OSV: https://osv.dev/vulnerability/CVE-2024-8291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8291/
Summaries are generated and may contain mistakes; the official description above is the record.
