# CVE-2024-8309: SQL Injection in langchain-ai/langchain

> Attackers can inject malicious queries via prompts to manipulate, exfiltrate, or delete database data in LangChain applications.

- **Severity:** Medium 4.9 (`CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-45pg-36p6-83v9, MINI-48v9-v2v7-j6jr, PYSEC-2024-115, PYSEC-2026-1507

## What is CVE-2024-8309?

CVE-2024-8309 is a medium-severity SQL injection vulnerability in langchain-ai/langchain, published on 29 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in the GraphCypherQAChain class of langchain-ai/langchain version 0.2.5 allows for SQL injection through prompt injection. This vulnerability can lead to unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-8309?

7 open source packages ship an affected version, including langchain and langchain-community. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain` | PyPI | All versions | 0.2.0 |
| `langchain` | PyPI | All versions | 0.2.0 |
| `langchain` | PyPI | All versions | 0.2.0 |
| `langchain` | PyPI | All versions | 0.2.0 |
| `langchain-community` | PyPI | From 0.2.0 | 0.2.19 |
| `langchain-community` | PyPI | From 0.2.0 | 0.2.19 |
| `langchain-community` | PyPI | From 0.2.0 | 0.3.0 |

Products: Langchain Langchain.

## How do I fix CVE-2024-8309?

Upgrade langchain to 0.2.0 or later.

## Is CVE-2024-8309 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8309 exists.

Public exploit code:

- A PoC for CVE-2024–8309 (github_poc): https://github.com/liadlevy/CVE-2024-8309

## Other vulnerabilities in langchain-ai/langchain

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8309 and fix it if it is affected.

What it is: CVE-2024-8309 is a medium-severity SQL injection vulnerability in langchain-ai/langchain, published on 29 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8309 exists.

Affected packages and fixed versions:
- langchain (PyPI): affected all versions; fixed in 0.2.0
- langchain (PyPI): affected all versions; fixed in 0.2.0
- langchain (PyPI): affected all versions; fixed in 0.2.0
- langchain (PyPI): affected all versions; fixed in 0.2.0
- langchain-community (PyPI): affected from 0.2.0; fixed in 0.2.19
- langchain-community (PyPI): affected from 0.2.0; fixed in 0.2.19
- langchain-community (PyPI): affected from 0.2.0; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8309/ (Markdown: https://insights.sbomify.com/CVE-2024-8309/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8309
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8309
- OSV: https://osv.dev/vulnerability/CVE-2024-8309

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8309/
Summaries are generated and may contain mistakes; the official description above is the record.
