CVE-2024-8311 Improper Protection of Alternate Path in GitLab
Authenticated users can bypass CI/CD variable overwrite protection by including a template, undermining pipeline security controls in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-8311?
CVE-2024-8311 is a medium-severity vulnerability in Gitlab Gitlab, published on 12 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered with pipeline execution policies in GitLab EE affecting all versions from 17.2 prior to 17.2.5, 17.3 prior to 17.3.2 which allows authenticated users to bypass variable overwrite protection via inclusion of a CI/CD template.
Weakness: CWE-424
Which versions are affected by CVE-2024-8311?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.2.0 | 17.2.5, 17.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-8311?
Upgrade gitlab to a fixed version for your release line: 17.2.5 or 17.3.2.
Is CVE-2024-8311 being exploited?
There is no known exploitation of CVE-2024-8311 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-8311, GHSA-947f-qh3g-pcj5.