CVE-2024-8312 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

An attacker can inject HTML into the Global Search field on a diff view, leading to Cross-site Scripting (XSS) in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-8312?

CVE-2024-8312 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 24 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 15.10 before 17.3.6, 17.4 before 17.4.3, and 17.5 before 17.5.1. An attacker could inject HTML into the Global Search field on a diff view leading to XSS.

Weakness: CWE-79

Which versions are affected by CVE-2024-8312?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.10.017.3.6, 17.4.3, 17.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-8312?

Upgrade gitlab to a fixed version for your release line: 17.3.6, 17.4.3 or 17.5.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-8312 being exploited?

There is no known exploitation of CVE-2024-8312 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8312, GHSA-8r4j-q2x9-54v8, UBUNTU-CVE-2024-8312.

Is CVE-2024-8312 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free