# CVE-2024-8353: GiveWP – Donation Plugin and Fundraising Platform <= 3.16.1 - Unauthenticated PHP Object Injection

> Unauthenticated attackers can achieve remote code execution and delete arbitrary files via PHP object injection in the GiveWP WordPress plugin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Sep 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-vpc6-qr46-3mw7

## What is CVE-2024-8353?

CVE-2024-8353 is a critical unsafe deserialization vulnerability in Givewp Givewp, published on 28 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.16.1 via deserialization of untrusted input via several parameters like 'give_title' and 'card_address'. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to delete arbitrary files and achieve remote code execution. This is essentially the same vulnerability as CVE-2024-5932, however, it was discovered the the presence of stripslashes_deep on user_info allows the is_serialized check to be bypassed. This issue was mostly patched in 3.16.1, but further hardening was added in 3.16.2.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-8353?

It affects 1 product.


Products: Givewp Givewp.

## How do I fix CVE-2024-8353?

No fix has been published for CVE-2024-8353 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-8353 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8353 exists.

Public exploit code:

- GiveWP PHP Object Injection exploit (github_poc): https://github.com/EQSTLab/CVE-2024-8353
- Proof-of-Concept for CVE-2024-5932  GiveWP PHP Object Injection  (github_poc): https://github.com/0xb0mb3r/CVE-2024-8353-PoC
- GiveWP Unauthenticated Donation Process Exploit (metasploit)
- GiveWP Donation Plugin <= 3.16.1 - Unauthenticated PHP Object Injection (nuclei): http/cves/2024/CVE-2024-8353.yaml

## Other vulnerabilities in Givewp Givewp

- [CVE-2024-5932](https://insights.sbomify.com/CVE-2024-5932/): Deserialization in GiveWP – Donation Plugin and Fundraising Platform (critical 10.0)
- [CVE-2024-37099](https://insights.sbomify.com/CVE-2024-37099/): WordPress GiveWP plugin <= 3.14.1 - Unauthenticated PHP Object Injection vulnerability (critical 10.0)
- [CVE-2025-0912](https://insights.sbomify.com/CVE-2025-0912/): GiveWP – Donation Plugin and Fundraising Platform <= 3.19.4 - Unauthenticated PHP Object Injection (critical 9.8)
- [CVE-2025-22777](https://insights.sbomify.com/CVE-2025-22777/): WordPress GiveWP Plugin <= 3.19.3 - PHP Object Injection vulnerability (critical 9.8)
- [CVE-2024-12877](https://insights.sbomify.com/CVE-2024-12877/): GiveWP – Donation Plugin and Fundraising Platform <= 3.19.2 - Unauthenticated PHP Object Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8353 and fix it if it is affected.

What it is: CVE-2024-8353 is a critical unsafe deserialization vulnerability in Givewp Givewp, published on 28 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8353 exists.

Affected product: Givewp Givewp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8353/ (Markdown: https://insights.sbomify.com/CVE-2024-8353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8353
- OSV: https://osv.dev/vulnerability/CVE-2024-8353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8353/
Summaries are generated and may contain mistakes; the official description above is the record.
