# CVE-2024-8402: Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab

> A Maintainer can execute arbitrary code via command injection in the Google Cloud IAM integration feature of GitLab EE.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2025
- **Updated:** 13 Mar 2025
- **Also known as:** BIT-gitlab-2024-8402, GHSA-xq5v-g7v7-8q74

## What is CVE-2024-8402?

CVE-2024-8402 is a low-severity command injection vulnerability in Gitlab Gitlab, published on 13 Mar 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in GitLab EE affecting all versions starting from 17.2 before 17.7.7, all versions starting from 17.8 before 17.8.5, all versions starting from 17.9 before 17.9.2. An input validation issue in the Google Cloud IAM integration feature could have enabled a Maintainer to introduce malicious code.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-8402?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 17.2.0 | 17.9.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-8402?

Upgrade gitlab to 17.9.2 or later.

## Is CVE-2024-8402 being exploited?

There is no known exploitation of CVE-2024-8402 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8402 and fix it if it is affected.

What it is: CVE-2024-8402 is a low-severity command injection vulnerability in Gitlab Gitlab, published on 13 Mar 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-8402 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 17.2.0; fixed in 17.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8402/ (Markdown: https://insights.sbomify.com/CVE-2024-8402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8402
- OSV: https://osv.dev/vulnerability/CVE-2024-8402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8402/
Summaries are generated and may contain mistakes; the official description above is the record.
